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1. INTRODUCTION 
The British Columbia (B.C.) Ministry of Water, Land and Resource Stewardship (WLRS) Biotic Ligand 
Model (BLM) software (Version 0.08) automates the calculation of long-term chronic and short-term 
acute water quality guidelines (WQG) for nickel (Ni) for the protection of aquatic life. A full technical 
description of the toxicity data set and derivation procedure can be found in the Nickel Water Quality 
Guideline for the Protection of Freshwater Aquatic Life-Technical Report document. The software uses 
two separate toxicity databases for chronic and acute Ni exposures for a diverse mixture of aquatic 
organisms, including plants, invertebrates, fish, and amphibians. The BC Ni BLM software is used to 
normalize the toxicity database to site-specific water chemistry, which allows for consideration of the 
effects of certain water quality parameters on bioavailability. The BC Ni BLM software requires the input 
of site-specific water quality information to calculate guideline values. The user can choose to run either 
the full BLM model that requires 11 input parameters or the simplified model that requires 4 input 
parameters and estimates the others.   

The BC Ni BLM software is based on the BLM software created by Windward Environmental (version 
3.60.2.50). Note that BLM data files created using the older version of the BLM Windows® Interface can 
be used directly with BC Ni BLM. 

This document describes the requirements for running the BC Ni BLM software, details the data 
requirements, and provides a step-by-step guide to using the various features using an example BLM 
data file.  

2. SETUP AND INSTALLATION 

2.1. SYSTEM REQUIREMENTS 
The BC NI BLM software is designed for use with Microsoft Windows®. The minimum requirements and 
the recommended system configurations are described below.  

• Minimum system requirements 
✓ PC-compatible, Intel Pentium 233 MHz 
✓ Microsoft Windows® 95/98/2000/ME/XP/Vista/Win7 
✓ 32 MB RAM 
✓ 30 MB free disk space 

• Recommended system configuration 
✓ Intel Pentium 3,500 MHz 
✓ 64 MB RAM 
✓ 100 MB free disk space 

Even though the BC NI BLM software can be run on a system with the specified minimum requirements, 
the recommended system configuration or faster is recommended to minimize computation time.  

2.2. INSTALLING THE BC Ni BLM SOFTWARE 
Install the BC NI BLM software from the setup file “bc_ni_blm_setup.exe“ and follow the prompts. The 
setup program will guide the user through a straightforward installation process, querying the user for 
information on where to install the necessary files (Figure 2.1). During the installation, a shortcut to the 
BC Ni BLM application will be added to the ‘Programs’ sub-menu within the ‘Start’ menu on the 
Microsoft Windows® desktop. In addition, the BC Ni BLM application will also be registered in the 
system registry so that the BLM data files created by the user can be accessed directly by just double-
clicking on the file name. 

https://www2.gov.bc.ca/gov/content/environment/air-land-water/water/water-quality/water-quality-guidelines/draft-water-quality-guidelines
https://www2.gov.bc.ca/gov/content/environment/air-land-water/water/water-quality/water-quality-guidelines/draft-water-quality-guidelines
https://www2.gov.bc.ca/gov/content/environment/air-land-water/water/water-quality/water-quality-guidelines/draft-water-quality-guidelines
https://www2.gov.bc.ca/gov/content/environment/air-land-water/water/water-quality/water-quality-guidelines/draft-water-quality-guidelines
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Figure 2.1. Installation directory screen for the BC NI BLM software setup program. 

3. STARTING THE APPLICATION 
To start the BC NI BLM, select ‘Start -----> Programs -----> British Columbia Nickel BLM -----> British 
Columbia Nickel BLM’ on the Microsoft Windows® desktop. The user will be presented with the screen 
shown in Figure 3.1., which contains the user input areas and the various functions of the BC NI BLM. 

 

Figure 3.1. Opening screen for the BC NI BLM application. 

Existing BLM data files created using other versions of the BLM Windows® Interface can be opened 
directly by double-clicking on the file name through a file system manager, such as Microsoft Windows® 
Explorer. 

4. RUNNING THE APPLICATION 
The following subsections describe the various functions and features available in the BC NI BLM 
Windows® Interface and its various predictive capabilities. 

4.1. Quick Start Guide 
Steps 1-7 provide an overview of the user’s manual for quick application of the BC NI BLM. More details 
are provided in the following subsections.    

Step 1: Enter water chemistry data or upload a saved ‘.blm’ or ‘.blme’ file (see sections 4.6 and 4.3.1); 

Step 2: Save file on the desired destination on your computer (see Section 4.3.1); 
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Step 3: Select chronic/acute database (see Section 4.3.4);  

Step 4: Step 5: Select run (see Section 4.4.4); 

Step 5: Open the output directory suggested by the software (see Section 4.4.4); 

Step 6: Obtain the acute/chronic WQG from the ‘.txt’ file produced by the software (see Section 6). 

4.2. Description of Interface 
Figure 4.1 shows the BC NI BLM application. The interface provides an easy-to-use editor to construct 
input files for the BC NI BLM containing site-specific water chemistry data, checks and validates user 
input data to ensure the values entered for any given parameter are within the range for which the BC 
NI BLM has been calibrated, and runs the BC NI BLM to calculate WQGs. The interface window is divided 
into four areas based on their functionality. Each of these is described in the following subsections. 

 

Figure 4.1. Opening screen for the BC NI BLM application. 

4.3. Menu Bar 
The Menu Bar located at the top of the interface window provides the user with a range of functions 
and features described in the following sections. 

4.3.1. File 

The File menu (Figure 4.2) includes basic file management utilities to: create a new BLM data file (New); 
open an existing BLM data file (Open…); save a BLM data file (Save); and save a BLM data file under a 
different name or in a new location (Save as…). Shortcut keys (shown to the right of each item) are also 
available for the different functions in this menu item. Note that the BC NI BLM data files created by the 
interface application are given a ‘.blm’ or ‘blme’ extension for full or simplified chemistry, respectively. 
Clicking the ‘Open’ icon while in the full or simplified site chemistry tabs will filter for files with the 
extension of ‘.blm’ or ‘.blme’, respectively. 
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Figure 4.2. Snapshot of “File” menu item. 

BLM data files can also be opened directly by double-clicking on the BLM data file in a file system 
manager, such as Microsoft Windows® Explorer. This avoids having to first start the application and then 
navigate through the file menu to locate the BLM data file of interest. 

The Run Batches…function can be used to run several input files simultaneously. 

The Quit function can be used to quit BC NI BLM application. 

4.3.2. Edit 

The Edit menu provides basic editing functions such as Copy, Cut, and Paste (Figure 4.3). These functions 
can be performed on a single cell or multiple cells by highlighting the cell with the cursor (left click and 
drag) or by using the Shift + Arrow functions on the keyboard. The editing functions can also be applied 
using the shortcut keys shown to the right of each function. Note that it is also possible to copy and 
paste data from external programs, such as spreadsheet applications, into the BC NI BLM. 

 

Figure 4.3. Snapshot of Edit menu item. 

4.3.3. Options 

Figure 4.4 shows the functions available under the Options menu.   
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Show Engine Runs 

The run may take up to an hour when running several sites simultaneously, depending upon the 
computing power available. In these cases, it is recommended to select the Show Engine Runs option to 
show the software’s progress allowing the user to ensure the software is working properly. 

 

Figure 4.4. Snapshot of Options menu item. 

Save SSD Graphs 

The Save SSD Graphs feature allows the user to save a copy of the species sensitivity distribution (SSD) 
graph produced by the BLM software. The HC5 of the SSD is the base of the WGQ for the intended water 
chemistry. For each site a separate SSD will be produced and saved.  

HC5 Confidence Limits 

The HC5 Confidence Limits options allows the user to select the number of bootstrap samples used to 
calculate confidence limits for the SSD. The recommended number of samples is 100. The higher 
number of samples will take more time to process but provides better confidence intervals of the SSD. 

4.3.4. Inputs 

Figure 4.5 shows the options available under the Inputs menu. The units for all parameters can be 
changed by selecting the Set Units function. For each component, the available units are displayed in the 
Select Units menu to the right. The Dissolved Inorganic Carbon (DIC) concentration is needed to run BC 
NI BLM. DIC can be calculated from alkalinity and since alkalinity is a more routinely measured, BC NI 
BLM requests for alkalinity data by default. However, the Set Inorganic Carbon function allows the user 
to input DIC instead of alkalinity in case of availability. If neither of measured DIC or Alkalinity data is 
available, DIC can be estimated from atmospheric CO2.  

Database Option allows the user to specify the calculation of either acute or chronic WQGs. 

 

Figure 4.5. Snapshot of Inputs menu item. 



 

W A T E R  S C I E N C E  S E R I E S  N o .  W Q G - 0 3 - 2  10 

 

4.3.5. Help 

The User’s Guide for the BC NI BLM can be accessed under the Help menu item (Figure 4.6). The About 
BLM option provides contact information for technical support. The Create Debug Log can be used to 
directly contact the developers of BC NI BLM (Windward Environmental) if the user faces a problem 
while working BC NI BLM.  

 
Figure 4.6. Snapshot of Help menu item. 

4.3.6. Language 

The user can select either English or French from the Language menu item.  

4.4. Tool Bar 
The Tool Bar provides shortcuts to some BC NI BLM functions (Figure 4.7). 

 

Figure 4.7. Tool Bar menu icons. 

4.4.1. Standard File Operations 

New File: this shortcut allows the user to create a new file for water chemistry input (Section 4.3.1). 

Open File: this shortcut provides quick access to the BC NI BLM data files (Section 4.3.1). If the BC NI 
BLM data file being edited has changed since the last time it was saved and the user tries to open 
another file, the user will be asked if the current data file should be saved prior to opening another. 

Save File: this shortcut allows quick saving of the BC NI BLM data file (Section 4.3.1). The data file will be 
saved with the same, existing name. If the user wishes to save the file under a different file name, the 
menu bar item File → Save As should be chosen. 

4.4.2. Standard Edit Operations 

Shortcuts for basic editing functions such as Copy, Cut, and Paste are provided and can be used to edit 
the water chemistry data at any point (Section 4.3.2). 
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4.4.3. Check Inputs 

The range of parameter values used to develop and calibrate the BC NI BLM are listed in Table 4.1. 
These ranges were taken from chronic and acute toxicity studies that considered the effects of water 
chemistry (e.g., pH, DOC, or hardness cations) on Ni bioavailability. The BC NI BLM is only valid within 
these data ranges. After creating a BC NI BLM data file, the user may wish to check the water chemistry 
inputs to verify whether the parameter values are within the overall range for which the BC NI BLM has 
been calibrated, and to see whether data for all the parameters necessary for a BC NI BLM prediction 
have been specified. Clicking on this icon generates an input check report that contains information on 
which parameters are out of range (i.e., too high or too low when compared with the range for which 
the BC NI BLM has been calibrated) and which parameters are missing for any given input row. Figure 
4.8 shows an example of an input check report. 

If water quality input values are greater or less than these ranges, the BC NI BLM software automatically 
applies the upper or lower bounds while calculating WQGs. 

Table 4.1. Ranges of values for BLM input parameters. 

Parameter Lower Bound Upper Bound 

Temperature (oC) 4 27 

pH 3.5 8.9 

DOC (mg/L) 0.032 25 

Humic acid content (%) 0.01 99 

Calcium (mg/L) 5.428 392 

Magnesium (mg/L) 1.547 115 

Sodium (mg/L) 0.00751 322 

Potassium (mg/L) 3.91e-6 166.86 

Sulfate (mg/L) 0.51 890 

Chloride (mg/L) 0.0414 550 

Alkalinity (mg/L) 0.01 728 

Hardness (mg/L) 20 1100 

 

 

Figure 4.8. Example of an “Input Check Report” generated by the Check Inputs function. 
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4.4.4. Run BLM 

The Run BLM icon is used to launch the BC NI BLM program to calculate WQGs for the user-specified 
water chemistry in the data file currently open. If the data file has unsaved changes, the user is given the 
option of saving the changes prior to running the BC NI BLM. The program will use either the chronic or 
acute database, depending on which guideline was selected from the Inputs Menu (see Section 4.3.4), 
and calculates the WQG for each row in the database. The runtime for BC NI BLM calculations can vary 
from a few seconds to a few hours depending on the number of input rows in the data file and the 
database selected (chronic or acute). Upon completion, the user is informed of the names and the 
locations of the output files, and given the option to open the directory, as shown in Figure 4.9. 

 

Figure 4.9. Example of the notification window shown at completion of BC NI BLM run. 

4.5. Data File Description 
The Data File Description field (Figure 4.10) allows the user to insert comments describing the BC NI BLM 
data file which will be saved with the water chemistry data entered by the user. Although this function is 
not critical to the function of the BC NI BLM, it is useful for record-keeping and quality assurance/quality 
control purposes. 

 

Figure 4.10. Snapshot of BC NI BLM application  
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Item Description 

Located at the very bottom of the interface window, this area displays a brief description of the feature 
over which the cursor is currently positioned. 

4.6. Site Chemistry Input Tabs 
There are two options for entering the water chemistry data depending on the parameters available: 
Site Chemistry (i.e., full site chemistry) and Simplified Site Chemistry.     

4.6.1. Site Chemistry  

This region of the interface window contains a spreadsheet-based editor, which organizes the various BC 
NI BLM input data in a columnar format such that the chemistry for each discrete water sample can be 
specified in a separate row. Two additional columns are provided for labeling the sites and samples in a 
given BC NI BLM data file. Figure 4.11 shows the columns available for user input. 

 

Figure 4.11. Columns for data input in the BC NI BLM. 

The BC NI BLM predicts Ni toxicity in aquatic systems and calculates WQGs for a site based on ambient 
water chemistry. The user is required to provide data describing the physical and chemical properties of 
the site water. The data requirements of the BLM are conventional physical and chemical parameters 
that are listed in Table 4.2. Some of these parameters have an important effect on BC NI BLM 
predictions, while others have only minor effects. 

Table 4.2. Water chemistry factors necessary to run the BC NI BLM, their unit and relative importance in 
calculation of WQGs. 

Factor Unit Importance 

Temperature °C Low 

pH NA High 

Dissolved organic carbon (DOC) mg/L High 

Humic acid fraction of DOC % Low 

Calcium mg/L High 

Magnesium  mg/L High 

Sodium  mg/L High 

Potassium  mg/L Low 

Sulfate mg/L Low 

Chloride mg/L Low 

Alkalinity mg/L High 
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Nickel concentrations are not required for the model to calculate WQGs, however, this field is retained 
to allow compatibility with other BLM versions. Nickel concentrations entered will not affect the WQG 
calculations but are included in the output text file for comparison with the WQG. 

4.6.2. Simplified Site Chemistry 

The Simplified Site Chemistry tab provides an option when all the water chemistry factors are not 
available. It differs from the Site Chemistry tab in that it only requires data for temperature, pH, DOC 
and hardness (mg/L as CaCO3) to run the BC NI BLM. Selecting the Simplified Site Chemistry tab provides 
a simpler site chemistry data input spreadsheet (Figure 4.12). 

Additionally, there is a side bar where the ion ratios can be set. The ion ratios will vary depending on 
watershed geology. The default values provided are the median ion ratios for B.C. and can be used if the 
ratios are unknown. These values can be changed to match the conditions of the site or test and can be 
reset to the default values at any time by clicking the Restore Default Values button at the bottom of the 
box. The Select Ion Ratios button allows the user to select default ion ratios for other regions of North 
America. Note that this is not recommended for calculating WQGs in B.C.; this option is included only to 
make the BC NI BLM compatible with other versions of BLM Windows® Interface. 

After the simplified site chemistry data has been entered, the BC NI BLM estimates the missing water 
chemistry information while calculating WQGs. Due to the uncertainty in estimating the absent water 
chemistry data, a cautious strategy was employed to guarantee that the WQGs generated by the 
simplified BC BLM do not surpass the values generated by the complete BC BLM. For this purpose, a 
correction factor was introduced to reduce the guideline values derived from the simplified chemistry 
BLM, ensuring that they do not exceed the corresponding values based on the full chemistry data. 

 
Figure 4.12. Snapshot of Simplified Site Chemistry inputs and ion ratios. 

When additional water chemistry data for the simplified option are available (e.g., major ions), but 
insufficient for the full BC NI BLM, the following steps should be taken: 

• Enter the parameters in the Simplified Site Chemistry tab; 

• Switch to the full Site Chemistry tab and replace the estimates for parameters with the available 
measured values; 

• If alkalinity data are available, the Set Inorganic Carbon option should be selected from the 
Inputs menu and then Closed System, Input Alkalinity should be selected (Figure 4.13). An 
additional column for alkalinity will appear and the data are entered there. 
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• If the user is missing calcium, magnesium, or alkalinity from the full chemistry, but is using the 
full chemistry tab in the software, then the correction factor needs to be added manually. The 
correction factor can be used from the below equation (the equation is presented as an Excel 
function):  
 
𝐶𝐹𝑙𝑜𝑛𝑔−𝑡𝑒𝑟𝑚 = min⁡(0.8371,max(0.5446,−0.1067 ∗ 𝑙𝑜𝑔10(𝐻𝑎𝑟𝑑𝑛𝑒𝑠𝑠,𝑚𝑔 𝐿⁄ ) + ⁡0.7846)) 

Note that if you switch back to the Simplified Site Chemistry tab without saving the data, the water 
chemistry data will be deleted. 

 

Figure 4.13. Snapshot of Set Inorganic Carbon menu item. 

5. EXAMPLE APPLICATION 
The BC NI BLM features an example application for demonstration purposes. This file, named ‘Lake 
Superior.blm,’ is installed along with the BC NI BLM and is in the “My Documents → British Columbia 
Nickel Biotic Ligand Model” folder. The file can be opened directly, by double-clicking on the file name 
through a file-system manager such as Microsoft Windows® Explorer or by first starting the BC NI BLM 
and selecting the file through the ‘File → Open’ action. This data file ‘Lake Superior.blm’ can be used to 
calculate a Ni WQG example produced by the BC NI BLM.  

6. DESCRIPTION OF OUTPUT FILES 
The contents of the output files will appear in an Output tab in the BC NI BLM User Interface once the 
model has finished running. The main output is written to a text file and saved to the same location as 
the input file, with the same name as the input file but with ‘.results’ appended (Figure 6.1). For 
example, using the input file ‘LakeSuperior.blm’ would create an output file titled 
‘LakeSuperior_Chronic.results.txt’ or ‘LakeSuperior_Acute.results.txt’ depending on the selection of 
Acute or Chronic databases (see Section 4.3.4). The output file includes the site chemistry used, and the 
WQG value calculated for each site. 

In addition, a bitmap image is produced for each site that illustrates the SSD for the different species in 
the toxicity database, normalized to the specified site chemistry (Figure 6.2). Solid lines on the graphic 
indicate the confidence intervals and the dotted line denotes the HC5. The bitmap file will not be 
produced if the “Save SSD Graphs” option is not selected. 

Two Microsoft Excel® files will also be produced: 

1. *.output: shows the water chemistry, HC5, confidence intervals, and guidelines values (Figure 
6.3). 
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2. *.ssdnormalized: shows the data associated with the toxicity datapoints for different species 
such as water chemistry, life stage, endpoint, and endpoint quantifiers it also shows the effect 
concentration normalized to the site water chemistry (). 

 

Figure 6.1. Example of a text file produced by BC NI BLM. 
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Figure 6.2. Example of the BC NI BLM SSD output file. 
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Figure 6.3. Example of the Microsoft Excel® file (*.output) produced by BC NI BLM. 

 

Figure 6.4. Example of the Microsoft Excel® file (*.ssdnormalized) produced by BC NI BLM. 

7. UNINSTALLING THE BC NI BLM 
To uninstall the BC NI BLM, select the Uninstall Utility using ‘Microsoft Windows® Start Menu → 
Programs → British Columbia Nickel Biotic Ligand Model → Uninstall.’ All files installed by the BC NI BLM 
during setup will be uninstalled. None of the files created by the user and saved in the BC NI BLM 
installation directory will be deleted during this process. These need to be manually deleted by the user, 
if so desired.  


