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1. Introduction 

1.1 Purpose of This Document 

This document is Volume 2 of a series of five documents supporting the VDYP system.  

 Volume 1 – VDYP Overview provides general information about VDYP7 application, and 

describes how to use this documentation set. 

 Volume 2 – WinVDYP7 User Guide is this document.  It describes how to use WinVDYP7, an 

easy to use interactive interface, designed to predict yields one stand at a time. 

 Volume 3 – VDYP7Console Interface Guide describes in detail how to use VDYP7Console, an 

interface to generate yield tables from text files in CSV format. 

This WinVDYP7 User Guide is written for those learning to use WinVDYP7 as well as a reference 

resource for more experienced users. Section 2 Getting Started has been designed to support 

experienced users. New users should read all the information in this guide. 

Appendix A provides detailed information regarding the processing messages that users may 

encounter; when running WinVDYP7 or either of the other two interfaces,  VDYP7Batch and the 

VDYP7Console, that are currently supported. 

1.2 How to Use This Document 

The information in this guide is organized as follows: 

 Section 1 – Introduction provides general information about the WinVDYP7 application, as 

well as tips on where to locate supporting information. 

 Section –2 – Getting Started describes the process of loading WinVDYP7 onto your computer 

in detail, gives a quick description of the major features, and describes each of the commands 

available to users. 

 Section 3 – WinVDYP7 Primer describes how to quickly begin using WinVDYP7. 

 Section 4 – Using WinVDYP7 describes in more detail how to run WinVDYP7. 

 Appendix A – Processing Messages describes the messages that can be generated by 

WinVDYP7 and the other interfaces. 

 Appendix B – Revision History lists the revision history of this guide. 
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Terms and 
conventions This document uses standard conventions for displaying information. 

Arial Narrow 
Bold 

Indicates text that you type or a button that 

you click. 

Italics 

 

Indicates a label that appears on a screen (for 

example, a field name or push-button label). 

Bold Used for emphasis. 

  
Indicates important information and 

warnings. 

  
Indicates application tips and tricks. 
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2. Getting Started 

2.1 Installing WinVDYP7 

For system requirements, downloading and installation instructions, a description of the configuration 

and other support files, see Volume 1 – VDYP7Overview (section 4). 

2.2 WinVDYP7 Processing Messages Overview 

From time to time, you may encounter problems associated with the performance of WinVDYP7.  

Before contacting support staff, refer to Appendix A for an explanation of processing messages. 
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3. WinVDYP7 Primer 

3.1 Running WinVDYP7 

Read this sub-section if you have experience using previous versions of WinVDYP7 and Microsoft 

Windows.  The high level concepts presented here will assist you to quickly begin using WinVDYP7.  

Detailed documentation describing the capabilities of WinVDYP7 can be found in Section 4 – Using 

WinVDYP7. 

 This section assumes you have already installed WinVDYP7.  If you have not, please 

refer Volume 1 – VDYPOverview (section 4). 

3.1.1 Starting WinVDYP7 

To run the WinVDYP7 application, click Start, Programs, VDYP7, WinVDYP7. 

 

Figure 2-1: Menu Navigation 

 

The following window will be displayed. 
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Figure 2-2: The Main Window 

 

3.1.2 Generating a Table 

Tables are used to display the growth of stands over time at two different utilization levels. To display 

the Species Information pane and begin defining your table: 

1. Click File, New Table. 

 



WinVDYP7 Primer 

6 Revised February 2019 Volume 2 - WinVDYP7 User Guide 

Figure 2-3: Species Information Pane 

 

2. Adjust the Species Composition and Species % of the stand you wish to model by clicking on the 

down arrows and selecting your choices. 

3. Adjust other properties of the model by clicking the Species % Derived By buttons.  

4. Click the Next button at the bottom of the screen to proceed to the Site Information pane. 

 To save your supplied values, click the Set as Default button on any pane and your 

entries will be the new defaults each time you open the Model Parameter Selection 

window to define a new table. 

 

 

Figure 2-4: Site Information Pane 

 

5. Adjust the BEC Zone by clicking on the down arrows and selecting your choice. 

6. Adjust other properties of the model by clicking the appropriate buttons, by clicking up or down 

arrows or by placing your cursor in the boxes and typing new values.  

7. Click the Next button at the bottom of the pane to go to the Stand Density pane. Click the Prev 

button to go back to the Species Information pane. 
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Figure 2-5: Stand Density Pane 

8. Adjust the stand properties of the model by clicking up or down arrows or by placing your cursor 

in the boxes and typing new values. 

9. Click the Next button at the bottom of the screen to go to the Additional Stand Attributes pane 

shown below. Click the Prev button to go back to the Site Information pane. 

 

Figure 2-6: Additional Stand Attributes Pane 
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10. The Additional Stand Attributes pane defaults to Use Computed Values. To adjust the additional 

stand attributes of the model, click the Supply Values button and WinVDYP7 will permit you to 

type new values. 

11. Click the Next button at the bottom of the screen to go to the Report Information pane shown 

below. Click the Prev button to go back to the Stand Density pane. 

 
Figure 2-7: Report Information Pane 

 

12. Use the Report Information screen to adjust the report information. 

13. Click the Run Model button at the bottom of the screen to run the model and generate the table. 

Click the Prev button to go back to the Additional Stand Attributes pane. See below for a 

sample report. 
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Figure 2-8: A Sample Report 

 Use the scroll bars or resize the table window to view all of the results. 
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3.1.3 Editing Table Properties 

You can adjust any of the settings you defined for your table and re-run the model by clicking on the 
table window to ensure it is active, then clicking Edit, Properties. The first pane will pop up (Species 

Information). Navigate through the panes to alter the properties you previously defined. 

 

Species 
Information

Site 

Information

Stand 

Density

Additional 

Stand 

Attributes

Report 

Information Run Model

Start

 

 

Figure 2-9: Model Parameter Selection Pane Navigation 

3.1.4 Saving a Table 

Save the table by clicking File, Save. A standard Save As window will pop up allowing you to name 

the table and specify a storage location. 

3.1.5 Comparing Tables 

You can model more than one table, and display all the table windows on your screen by clicking the 

Window menu and choosing Tile Vertical or Cascade. 

3.1.6 Printing a Table 

To print a table click File, Print. A standard Print window will pop up so you can send the table to 

your printer. 

 If you have created more than one table, select the table you want to print by clicking 

on the table to be printed (the title bar will change colour and the table will be 

displayed on top of the other tables), then click File, Print. 
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3.1.7 Exiting WinVDYP7 

 

Figure 2-10: Confirm File Save Dialog 

 

1. To exit WinVDYP7 click File, Exit or click the  button in the top right corner of the window. 

2. If you have made changes to any table(s) the above window will display: 

3. If you have made changes to multiple tables, click Yes to All to save all tables. Alternatively, you 
can choose to save each table independently by clicking the Yes or No buttons. You can also 

choose to save none of the tables by clicking No to All. 

4. If you choose to save a table, a standard Save As window will pop up allowing you to name the 

table and specify a storage location. 
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3.2 Using WinVDYP7 Menu Commands and Toolbar Buttons 

This sub-section is the reference for all menu commands and toolbar buttons available in 

WinVDYP7. 

3.2.1 The Main Window 

The main window appears as shown below.  When the window is open, you are running WinVDYP7. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 2-11: The Main Window 

3.2.1.1 Main Window Controls 

The controls available in the main window are common to all Windows applications, and are 
described below. 

 System Button: Activate by clicking or by pressing Alt-Space.  When activated, the menu 

shown below pops up. Click to choose a menu item. 

 
Figure 2-12: System Menu  
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 Title Bar: this bar displays the application name.  Hold the left mouse button down on it and 

move the mouse to move the window.  Double click to maximize the window to whole 

screen or, if already maximized, return to previous size. 

 Minimize Button: this button shrinks the main window down to an icon and places it near 
the bottom of your screen.  Use the Minimize Button to switch to another application 

without exiting WinVDYP7. 

 Maximize Button: this button expands the window to fill the entire screen.  If the window 

has already been maximized, clicking on this button will return it to its original size. 

 Close Button: Click this button to close WinVDYP7. 

 Menu Bar: this bar contains all available menus.  Click a menu name to display the menu 

items, or press the Alt key and the underlined letter of the menu you wish to display.  For 

instance, to activate the File menu, you can press the Alt and the F keys at the same time 

(Alt-F). 

 The menu bar provides different options depending on if a table is currently open or 

not.  For instance, the Edit menu does not appear until you open or create a table. The 

next section provides more details on the menu bar. 

 Tool Bar: this bar provides quick links to some of the menu items.  These buttons include: 

Button Function Menu Path 

 
New Table File, New Table 

 
Open Table File, Open 

 
Save Table File, Save or Save As 

 
Print Table File, Print 

 
Table Properties Edit, Properties 

 
Help Help, Contents (not yet available) 

 

 Working Area: Tables will default to display in this area, however you can shrink or 

minimize the WinVDYP7 window and display tables anywhere on your screen. 

 Status Bar: this bar displays status messages such as what the current button is as you move 

the mouse over it, and what WinVDYP7 is doing during a long calculation. 

 Resizing Border: hover your cursor over this border and your cursor will change to a two-

headed arrow. Press and drag to resize the window.  
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3.2.2 File Menu 

Two different File menus may display during a typical WinVDYP7 session, although only one 

is active at any one time.  Figure 2-13 and Figure 2-14 show these menus. 

 

 
Figure 2-13: File Menu – No Table Open 

 

 

 
 

Figure 2-14: File Menu – Table Open 
 

3.2.2.1 New Table 

Select New Table to open the Model Parameter Selection window and begin defining a new 

table. Activate this item in one of four ways: 

 Click on the File menu, and then click on the New Table menu item. 

 Press Alt-F to activate the File menu, then press T to select the New Table menu item. 

 Press Ctrl-T to directly activate this command without having to go through the File menu. 

 Click on the New Table toolbar button.  

For more information regarding the table parameters, refer to Section 4. 

3.2.2.2 Open 

Select Open… to display a table that you have previously saved to disk. Activate this item in 
one of four ways: 

 Click on the File menu, then click on the Open… menu item. 

 Press Alt-F to activate the File menu, then press O to select the Open… menu item. 

 Press Ctrl-O to directly activate this command without having to go through the File menu. 

 Click on the Open... toolbar button.  

When selected, you cause a standard windows File Open window to open (Figure 2-15) that 

lists only table (.TBL) files. 

 



WinVDYP7 Primer 

Volume 2 - WinVDYP7 User Guide Revised February 2019 15 

 
Figure 2-15: File Open Dialog 

 

Select the table you wish to open and press OK; or click Cancel to close the Open window. 

3.2.2.3 Close 

This menu item closes the currently selected table and is only available when there is at least 
one table open in the main WinVDYP7 window. Activate this menu item in one of three ways: 

 Click the File menu, and then click the Close menu item. 

 Press Alt-F to activate the File Menu, then press C to select the Close menu item. 

 Press Ctrl-F4 to close the window directly without having to go through the File menu. 

When you close an open table that has been modified, you will be asked if you want to save 

the changes first.  

If you click Yes, a standard file Save As window will appear. 

3.2.2.4 Save 

This menu item will save the current table to disk and is only available when you have a table 

open. Activate this item in one of four ways: 

 Click the File menu, then click the Save... menu item. 

 Press Alt-F to activate the File menu, then press S to select the Save... menu item. 

 Press Ctrl-S to directly activate this command without going through the File menu. 

 Click on the Save... toolbar button.  
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When selected, the file is saved. If the table is new or has been changed, a standard file Save 

As window (see Figure 2-16) will open, so you can accept the default name and location, or 
give the table a name and storage directory. 

 
Figure 2-16: File Save / Save As Dialog 

 

Click OK and the table will be saved to the file named in the window. 

If you prefer not to save the file, click on the Cancel button. 

3.2.2.5 Save As 

This menu item will open a standard file Save As window (Figure 2-16).  This command is 

only available when you have a table open. 

Activate this item in one of two ways: 

 Click on the File menu, then click on the Save As... menu item. 

 Press Alt-F to activate the File menu, then press A to select the Save As... menu item. 

When selected, a file Save As window is displayed (see Figure 2-16) allowing you to assign a 
different file name by specifying a new name in the file name box. 

If you prefer not to save the file, click on the Cancel button to stop the operation. 

 A new file saved this way is completely independent of the first, and you may wish to 

open the first again to create another copy of the table. This facility provides a 

convenient mechanism to create a few tables that are similar.   
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3.2.2.6 Save As Text 

This menu item will save the current table as an ordinary text file.  This command results in a 

text file which looks exactly like the report in the table window.  This command is only 
available when you have a table open and in the current working window. 

 It is important to remember that tables saved as a text files cannot be opened by 

WinVDYP7. If you want to save a table so that WinVDYP7 can open it again, use the 

Save or Save As commands. 

You use a text reader such as Notepad to open text files, and text files can also be imported 
into many other programs such as Microsoft Excel.   

Activate this item in one of two ways: 

 Click the File menu, then click the Save As Text menu item. 

 Press Alt-F to activate the File menu, then press T to select the Save As Text menu item. 

A file Save As window will be displayed allowing you to name and store the text file. 

3.2.2.7 Print 

This menu item will print the current table.  This command is only available when you have a 
table open. 

Activate this item in one of four ways: 

 Click the File menu, then click the Print menu item. 

 Press Alt-F to activate the File menu, then press P to select the Print menu item. 

 Press Ctrl-P to directly activate this command without having to go through the File menu. 

 Click on the Print toolbar button.  

When selected, a standard Print Setup window will appear (see Figure 2-17). 

If you prefer not to print the file, click the Cancel button to stop the operation. 

 
 

Figure 2-17: Print Setup Window 
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3.2.2.8 Exit 

This menu item will exit WinVDYP7. There are four ways to pick this menu item: 

 Click the File menu, then click the Exit menu item. 

 Press Alt-F to activate the File menu, the press E to select the Exit menu item. 

 Click on the system button (Figure 2-11) of the WinVDYP7 main window then select the 

Close item. 

 Press Alt-F4 to exit WinVDYP7 directly without having to go through any menus. 

When this command is activated, WinVDYP7 checks to see if any of the open tables need to 

be saved either because they are new or because you have made changes to them that you have 
not yet saved.  If WinVDYP7 finds such tables, the window in Figure 2-18 is displayed. 

 

 
 

Figure 2-18: Confirm File Save Window 

Each time the window in Figure 2-18 is displayed, you may answer in one of the following 
ways: 

 Yes: the table is saved just as if you had clicked on the File menu, then on the Save menu 

item. 

 Yes to All: all tables are saved to their respective files automatically and this window will not 

be displayed again.  New tables will be given default names and stored in the current 

directory. 

 No: the current file is not saved to disk.  Recent changes to this file are lost. 

 No to All: all tables are not saved and all changes will be lost. 

 Cancel: this table is not saved, and WinVDYP7 will not exit.  You are returned to the 

program with all remaining tables open and in their same state. 

Once all unsaved files have been prompted for action on saving or not, and assuming you did 
not select the Cancel button, the main window will disappear indicating WinVDYP7 has shut 

down. 
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3.2.3 Edit Menu 

The Edit menu appears only if you have at least one table open. 

 

 
Figure 2-19: Edit Menu 

 

3.2.3.1 Properties 

This menu item allows you to open the Model Parameter Selection window to change the 
table parameters.  It is available only when you have a table open. 

Activate this item in one of four ways: 

 Click on the Edit menu, then clicking on the Properties... menu item. 

 Press Alt-E to activate the Edit menu, then press P to select the Properties menu item. 

 Move your mouse so the cursor is over a table and click the right mouse button. 

 Click on the Properties toolbar button.  

Once you have made changes to the properties of the stand, you can click on the OK button to 
generate the new table, or you can click on the Cancel to abandon any changes you may have 

made. 

 For more information regarding the table parameters, refer to Appendix A. 

3.2.3.2 Copy 

Use the Copy command to copy a table to the clipboard for pasting into a document in another 

application such as a word processor.  This command is available whenever a table is open. By 

default, when you activate this command, the entire table is copied.  Before printing a table it 
may be necessary to switch to landscape orientation.  If the table lines wrap or columns are not 

lined up, try selecting Courier font size 8.   

Activate this command in one of three ways: 

 Click on the Edit menu, then click on the Copy menu item. 

 Press Alt-E to activate the Edit menu, then press C to select the Copy menu item. 

 Press Ctrl-C to short cut using any menus. 
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The View menu allows you to change the appearance of some of the features of the main 

WinVDYP7 window, and to keep the WinVDYP7 log file window open. 

Click on the Toolbar and Status Bar menu items under View to activate and deactivate the 

toolbar and the status bar.  See Figure 2-20. These commands are useful for maximizing the 
space available on the screen. 

 
Figure 2-20: View Menu 

3.2.3.3 Tool Bar 

By successively clicking on this command, you will cause the tool bar to disappear and to 

reappear. There are two ways to activate this command: 

 Click the View menu, then click the Toolbar menu item. 

 Press Alt-V to activate the View menu, then press T to select the Toolbar menu item. 

After selecting this item, the check mark will either disappear or reappear.  If it disappears, so 

will the toolbar.  By activating this command again, the toolbar will reappear. 

3.2.3.4 Status Bar 

By successively clicking on this command, you will cause the status bar to disappear and to 

reappear.  There are two ways to activate this command: 

 Click the View menu, and then click the Status Bar menu item. 

 Press Alt-V to activate the View menu, then press S to select the Status Bar menu item. 

After selecting this item, the check mark will either disappear or reappear.  If it disappears, so 

will the Status Bar at the bottom of the main window.  By activating this command again, the 
status bar will reappear. 
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3.2.3.5 VDYP7 Log File 

 
Figure 2-21: Log File Window 

Click on the VDYP7 Log File menu item to open the Log File window. The Log File window 

allows you to monitor the operations being performed by WinVDYP7 (Figure 2-21). 

The physical location for this file is in the VDYP_CFG folder under the WinVDYP7 

installation folder as the title bar in Figure 2-21 suggests.  It is overwritten with each time a 
model is computed. 

3.2.4 Window Menu 

This menu allows you to select and manipulate the table windows you have open, and the Log 

File window.  Using this menu you can create orderly arrangements of all open windows or 

select a particular one from a large set of open tables.  See Figure 2-22. 

 
Figure 2-22: Window Menu 

3.2.4.1 Cascade 

This command causes all the open windows to overlap each other with the title bars showing.  

This method is the default method of opening windows such that if you opened a whole series 
of tables in succession, this is how they would display. This command is only available when 

at least one table is open. 

Activate this command in one of three ways: 

 Click the Window menu, then click the Cascade menu item. 

 Press Alt-W to activate the Window menu, then press C to select the Cascade menu item. 

 Press Shift-F5 to activate this command directly. 



WinVDYP7 Primer 

22 Revised February 2019 Volume 2 - WinVDYP7 User Guide 

3.2.4.2 Tile Horizontal 

This command causes all open windows to line up one over the other, filling the entire width 

of the main window.  Windows are sized and positioned to line up evenly with one another. 
This command is only available when at least one table is open. Activate this command in one 

of three ways: 

 Click on the Window menu, and then click on the Tile Horizontal menu item. 

 Press Alt-W to activate the Window menu, then press H to select the Tile Horizontal menu 

item. 

 Press Shift-F4 to activate this command directly without using the menus. 

 This command is especially useful for comparing two or more tables.  You can use 

this command to line up the tables and then use the scroll bars to view identical 

regions of both tables. 

3.2.4.3 Tile Vertical 

This command causes all open windows to line up side by side, filling the entire width and 
height of the main window.  Windows are sized and positioned to line up evenly with one 

another. This command is only available when at least one table is open. Activate this 

command in one of two ways: 

 Click on the Window menu, and then click on the Tile Vertical menu item. 

 Press Alt-W to activate the Window menu, then press V to select the Tile Vertical menu item. 

3.2.4.4 Arrange Icons 

From time to time you may wish to clean up the icons along the bottom of the main window.  
As windows open and close these icons tend to get spread out.  This command groups them 

neatly along the bottom of the main window and is only available when there is at least one 

table open. This command can be activated in one of two ways: 

 Click on the Window menu, and then click on the Arrange Icons menu item. 

 Press Alt-W to activate the Window menu, then press A to select the Arrange Icons menu item. 

3.2.4.5 Individual Windows 

This command allows you to select an individual table from all of the open tables.  When you 
have large numbers of windows open, it is sometimes hard to find the particular window you 

are looking for, especially if other windows conceal it. This command can be activated in one 

of two ways: 

 Click on the Window menu, and then click on the particular window you are interested in. 

 Press Alt-W to activate the Window menu, then press the number corresponding to the window 

you want to display.  For instance, in Figure 2-22, if you wanted the Table02 window, press 

2. 
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3.2.5 Help Menu 

The Help menu provides access to all help available through WinVDYP7. 

Currently, on-line help has not been written and therefore the main commands within this 

menu have been disabled.  When on-line help is available, these commands will be enabled 

and help will be provided.  See Figure 2-23. 

 
Figure 2-23: Help Menu 

3.2.5.1 This Window 

This command provides Help for the current window. 

3.2.5.2 Contents 

This command starts Help and provides a table of contents. 

3.2.5.3 Search for Help On 

This command asks you for a keyword about the topic you wish help on, and then provides a 

choice of all the help topics relating to that keyword. 

3.2.5.4 How to Use Help 

This command provides standard Windows help on how to use and navigate through the 

features of WinVDYP7 Help. 

This command is activated in one of two ways: 

 Click on the Help menu, then click on the How to use Help menu item. 

 Press Alt-H to activate the Help menu, then press H to select the How to use Help menu item. 
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3.2.5.5 About 

This command displays a window that provides you with information about WinVDYP7’s 
authors, version information and other system related information.  Figure 2-24 provides a 

sample of this window. 

 
Figure 2-24: About WinVDYP Window 

This window should probably be updated to Ministry of Forest, Lands, Natural Resource 

Operations and Rural Development 
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4. Using WinVDYP7 

4.1 Model Parameter Selection Panes 

The Model Parameter Selection window consists of five panes, each containing a different set of 

properties that can be set and manipulated.  You use the Model Parameter Selection panes to create or 

modify tables.  You can select File, New or Edit, Properties to display the first of these panes. For 

details on the various ways you can initiate the menu commands, see the previous section. 

The properties found on each pane are logically connected, and the panes always appear in the same 

order. You can move back or forward between the panes in the set.  These five panes are described in 

logical order in this section. 
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Figure 3-1: Model Parameter Selection Pane Navigation 

4.2 Common Navigation Buttons 
All of the panes have some commands in common. These commands are described here to avoid 

repetition. 

 Cancel Button: closes the Model Parameter Selection panes.  None of the changes you may have 

made to the properties are retained and the table is not recalculated. 

 Set As Default Button: this button causes the current set of properties in each of the panes to be 
saved as the default set.  This means that every time you create a new table from that point on, it 

will be created with those properties rather than the ones that were installed with WinVDYP7. 

 The Set As Default Button feature is handy if you want to create a number of similar 

stands with perhaps only one different property.  You could set the properties for the 

first stand, save them as the default, and then with each new table you create, you 

simply change the one or two properties for the next stand. 

 Prev Button: displays the previous pane in the series. 

 Next Button: displays the next pane in the series. 
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 Run Model Button: causes the table to calculate and display the results in a window according to 

the properties you selected. If you are running a new table, a new table window is opened to 

contain the results. If you have adjusted the properties of the current table, the results replace the 

previous results in the table window. 
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4.3 Species Information Pane 
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Figure 3-2: Model Parameter Selection – Species Information 

 

The Species Information pane allows you to set the species composition of the stand. 

 

Figure 3-3: Species Information Pane 

You can set up to six tree species as well as the relative percents by volume or basal area of each 

species.  The percents must always total up to 100.0%, if they don’t an error message will pop up. To 

change any of the species: 

1. To display a dropdown menu of all available species, click on the species box you wish to 

change.  

2. A selection of all available species will be displayed as in Figure 3-4.  Use the arrow keys or the 

scroll bars to select the species you wish. 
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Figure 3-4: Available Species List 

To change the corresponding species percents: 

1. Click on the percent field you wish to change or use the tab key until you reach the appropriate 

field. 

2. Type in the new percent directly or use the up/down arrows at the right edge of the field to 

increase or decrease by five percent increments. 

When you have finished composing the stand, check that: 

 Each species selected has a percent greater than 0; 

 The percentages are in descending order; 

 Each percent greater than zero has a corresponding species; and, 

 The species percents sums to 100%. 

If any of these conditions do not apply, you will get an error message when you try to move on to the 

next pane. 

The available species presented include 32 common species codes.  Generally, the species with the 

highest percent will be used to select the site index function used to project stand height as shown in 

the yield tables.  In the case of a tie for leading species, WinVDYP7 will select one and display it in 
the Site Species window. If two or more species are leading (highest and the same percentage), the 

species listed first is used for site index determination.  Second (and subsequent) species use this 

same selected function.  Heights for these non-leading species may be adjusted when calculating 

volumes to reflect trends found in natural stands. 

To adjust other properties of the model: 

 Click the Species % Derived By buttons, or click to place your cursor in the Sp Group, Sp Group 

% and Site Species boxes and type new values. 

To save your property adjustments, click the Set as Default button and the next time you display this 

screen your entries will display as the default. 

Click the Next button at the bottom of the screen to proceed to the Site Information pane shown 

below. 

SP Group (Species Group) – the level of species aggregation for which the per-hectare yields are 

predicted in VDYP7. 
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SP Group % (Species Percent) – percentage of the stand that the corresponding species group 

comprises. 

Site Species – species within the corresponding species group(s) used to determine the site index. 

Species % Derived By – On input tree species percentage is based either on relative gross volume or 

BA above a specified diameter limit.  Selecting species by volume restricts density input to Crown 

Closure (old FIP inventory standard).  The alternative choice allows BA and TPH to be supplied (VRI 

inventory standard).  In both cases the output species percentage will be by BA.  

4.4 Site Information Pane 
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Figure 3-5: Model Parameter Selection – Site Information 

 

The Site Information pane allows you to set the stand characteristics such as location and site quality 

of the stand, by species and apply volume modifiers to the generated volumes (where are the volume 

modifiers?).  Figure 3-6 has an example of this pane. 

 
 

Figure 3-6: Site Information Pane 

1. Adjust the BEC Zone by clicking the down arrow and selecting your choice.  
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Figure 3-7: BEC Zone Dropdown 

2. Site Species shows the tree species in the stand for the species group with the highest percent 
composition. Click the down arrow to show the site species for the second species group if one 

is present.  

3. Site Index Curve. The Ministry default curve for the site species. This field is populated 

automatically. 

4. For the first Site Species, you can choose to use a computed site index, or a supplied site index. 

Site information for the second site species, if applicable, can be entered using the same method 

selected for the first. 

Computed Site Index 

To use a computed site index: 

1. Ensure the Computed button is selected (filled in) by clicking on it.  This will enable the 

Age and Height fields and disable (gray out) the BHA 50 Site Index. 
2. Move to the Age field by clicking on it or using the tab key until it becomes the current 

field. 

3. Choose Age or Breast. If you chose Age, enter the age in years at which the height was 
measured.  This is measured in total years and refers to the total amount of time the stand 

has been growing from a seed. If you chose Breast enter the amount of time the stand has 

been growing since it reached breast height (1.3 m). 

4. Move to the Height field by clicking on it or using the tab key until it becomes the current 
field. 

5. Enter the height of the stand when it was at the age supplied in step 3.  This height is in 

meters. 
6. You will notice that as you make changes to the values in the age and height fields, the 

Height at BHA50 automatically changes as well.  This value automatically changes to the 

equivalent height implied by the age/height pair for the current species composition. 

 By selecting different float values, you can supply a different pair of site input values 

and have the third “floating” value computed automatically. 

The following fields affect the value in the Height at BHA 50 field: 

 Leading Species (from Species pane) 
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 Age from Calculated fields. 

 Height from Calculated fields. 

Making changes to any of these fields while using Calculated Site Index values will cause the 

Height at BHA 50 to be recalculated. 

Supplied Site Index 

In order to use the Supplied Site Index you: 

1. Ensure the Supplied radio button is selected (filled in) by clicking on it.  This will enable 
the Height at BHA 50 field to the right of it and disable (gray out) the two fields to the 

right of the Calculated radio button. 

2. Move to the Height at BHA 50 field by clicking on it or using the tab key until it becomes 
the current field. 

3. Enter the Site Index in meters. 

Supplying a Site Index value is important if you know the potential growth rate for a particular 

stand based on historical data or nearby stands but no stand has yet been planted. 

4.5 Stand Density Pane 
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Figure 3-8: Model Parameter Selection – Stand Density 

 

The Stand Density pane allows you to enter stand density characteristics, including the % Stockable 
Area, Basal Area, TPH, and Crown Closure.  The Min DBH Limit field cannot be edited.  The 

Current Diameter indicates the quadratic mean dbh calculated from the supplied Basal area and TPH. 
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Figure 3-9: Stand Density Pane This pane now includes Current diameter so the figure should be updated 

 

1. Click the up/down arrows to adjust the % Stockable Area. Percentages are selectable in 

increments of 5, or you can click inside the box and type any percentage. If you do not select a 

percentage, a default will be computed when the model is run. 

2. If you selected Species % by Basal Area in the Species Information pane, and Computed Site 

Index on the Site Information pane, you can enter the Basal Area,  and the TPH (Trees per 

Hectare) at the minimum DBH limit indicated. Otherwise, these fields are grayed out. 

3. If you selected to derive the Species % by Volume in the Species Information pane, and selected a 

Computed Site Index on the Site Information pane, you can specify the Crown Closure. 

Otherwise, these fields are grayed out. If you do not know the crown closure of the stand, it is 
recommended that a value of 0.0 be entered.  This will invoke a default crown closure as given 

in Appendix D. 

4.6 Additional Stand Attributes 
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Figure 3-10: Model Parameter Selection – Additional Stand Attributes 
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In the Additional Stand Attributes pane, you can use computed values, or supply values for Lorey 

Height and Whole Stem Volume, Basal Area and Whole Stem Volume, Close Utilization Volume, 
Close Utilization Net Decay Volume and Close Utilization Net Decay, Waste Volume by the units 

indicated. 

 

Figure 3-11: Additional Stand Attributes Pane 

1. The default for this page is to use computed values. 

2. If you choose to supply values click the Supply Values radio button the additional stand attributes 

will become editable fields. To adjust any value, double click in the field and the current value 

will be highlighted, at which point you can type in a new value. 

4.7 Report Information Pane 
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Figure 3-12: Model Parameter Selection – Report Information 

 

The Report Information Pane enables you to set the information you wish to see in the table output.  

You can set the Age Range, Volumes Reported, and the Minimum DBH Limit by Sp Group; choose 

whether you wish to see the Computed MAI or Species Composition, and add a table name. 
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Figure 3-13: Report Information Pane 

1. Move to the Age Range field by clicking the mouse on the field, or by pressing the tab key until 
the field becomes active. The Age Range field sets the range of years and what interval to list 

them in when the table window is displayed. 

2. Edit the field by typing in a new starting age, finishing age or age increment or by clicking on the 

up or down arrow buttons to scroll up and down. 

3. Select the Volumes Reported category by clicking the mouse to add or delete check marks. 

Multiple categories can be selected. 

4. Select the Include In Report category by clicking the mouse to add or delete check marks. 

Multiple categories can be selected.  

5. Select the Min DBH Limit by SP Group categories by clicking the mouse on the radio buttons. 

One category in each column can be selected. The number of columns that display for selection 

depends on settings in the VDYP.INI file. 

4.8 Running the Model 
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Figure 3-14: Model Parameter Selection – Run Model 

 

After you are finished defining properties for the stand, click the Run Model button to generate the 

table. 

4.9 Using Tables 

Tables provide growth information for height, diameter, volume and mean annual increment (MAI) 
information for a stand over time. They can also provide species composition as a percentage of total 

basal area for the stand. 

The resulting information is displayed in a formatted table with a header and follow-up information 

following.  The next section describes this format in detail. 

You can use these results for simple informative uses, to copy into a spreadsheet, where it can be 

graphed for a visual representation of the data, or to cut and paste into a word processor or 

spreadsheet for later analysis. 

This section describes in detail how tables are generated and saved, and the changes you can make to 

the table properties. 

4.9.1 Format Description 

Every table is formatted the same with minor variations no matter which choices you make for the 

properties that generated it.  Figure 3-15 shows a typical table and points out each of the important 

parts to take note of. 

There are a number of major sections in each table, some of which may or may not appear in any 

particular display of the report depending on the properties you selected. 

 Stand Composition: this top most section of the table always appears and summarizes the species 

composition of the stand.  The species are listed using their full names and percents refer to 

supplied values on the species information pane. 

In Figure 3-9, Douglas Fir comprises 85% of the volume at any particular age.  

 Tot Age – Years since germination.  Usually used with reference to stands of natural origin 

 Site Ht (Site Height) – Average height in meters for site trees of a specified tree species in a 

stand, typically the species with the greatest basal area.  Also the stand height predicted from a 

site index curve at given age. 

 Lorey Height – Height in meters of the tree of average basal area.  Typically above a given 

diameter limit, for all species combined or for an individual species.   

 Quad Std DIA (cm): This entry presents an estimate of the quadratic mean stand diameter 

measured outside the bark at breast height in centimeters.  That is, the diameter of the tree of 

average basal area. 

 BA (m**2/ha) – Basal Area. Total cross sectional area of all living trees measured outside bark 

at breast height measured in square meters per hectare (m2/ha) above a specified diameter limit. 

 TPH (Trees per Hectare) – total number of living trees per hectare above a specified diameter 

limit. 
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 Whole Stem VOL (m**3/ha) – The entire tree’s stem volume.  

 Computed Results: the predicted height, diameter, volume and MAI calculations for the 
utilization levels and age range you selected in the properties for this table.  These computed 

values are displayed and formatted as you see them in Figure 3-15 by default. If you wish to 

change the defaults, modify the format patterns in the VDYP.INI file. For example, a format of 

##0.00 produces a field width of six characters with two decimals of precision.  

 Notes: displays messages that you should take into account when interpreting the results in the 
table.  There may or may not be any notes displayed, depending on the properties you have 

defined for this stand.  In some cases, there may be several of them. 

 In Figure 3-15, this particular note indicates that actual percent stockable area used was 77%.  

 Table Properties: lists all the property settings that were used to compute this table.  This section 

is provided in order to allow easy reproduction of the results.  The properties are listed in two 
columns and completely describe the stand.  Some properties may not appear in this section if 

they were not selected. 

Just a note on the example.  The BA is creeping along, growing at about 0.2m2/ha per decade up 

to age 100 then starts booming at 2m2/ha per decade.  It seems to be a function of the TPH 

which declines to age 100, then increases up to age 130 and then starts a slow decline again.  

Some trees must be crossing the size threshold to cause the increase in TPH so I expected to see 

a decline in the Dbhq growth but it seems to be pretty steady.
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4.9.2 Modifying 

Once a table is displayed, you may wish to make changes to the table’s properties.  

To activate the Model Parameter Selection window for a particular table, perform the following steps: 

1. Ensure the table you wish to make changes to is the active window. 

2. Right click on the table window, or click Edit, Properties on the menu bar to display the first pane 

of the Model Parameter Selection window. 

3. Advance through the Model Parameter Selection windowpanes, making the necessary changes to 

the properties for this window (see Figure 3.1).  

4. At the last pane, click on the Run Model button. 

5. The table will be updated to show the results of your properties selections. 

4.9.3 Saving 

You can save tables in WinVDYP7 format, or as text files. Tables can be saved at any time. If you 

save in WinVDYP7 format, you can open the table again at a later time to continue working with it. 

If you save a table as a text file, you will not be able to open it using WinVDYP7. 

4.9.3.1 Saving as a WinVDYP7 File 

To save the table on your hard drive, LAN or to disk: 

1. Ensure the table you wish to save is the active window. 

2. Save the file in one of three ways: 

  - Press the Ctrl-S key combination to save the file directly. 

  - Click on the Save tool bar button. 

  - Click on the File menu, and then click on the Save or Save As menu items. 

3. If the file has not been previously been saved or you have selected Save As, a standard file 

window appears and asks you to point to a save location, and enter the table filename. 

 The file extension will default to .TBL. Do not change this default if you wish to 

reopen the table using WinVDYP7.  

4. After selecting the location and file name, click the OK button and the file will be saved. 
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Figure 3-16: File Save / Save As Window 

4.9.3.2 Saving As a Text File 

 If you save a table as a text file, you will not be able to open it using WinVDYP7. 

You may wish to store a table as a text file so you can read the report without having to use the 

WinVDYP7 application. You can open text files in different applications such as Notepad and 

Windows Excel and annotate. 

To save the table as a text file, follow the same instructions as given above for saving the table 

in WinVDYP7 format. Note that the file will save with the extension .TXT. See Figure 3-17. 

 

 

 
Figure 3-17: Save As Text File Window 
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4.9.4 Printing 

This menu item will print the current table.  This command is only available when you have a table 

open. 

To print a table: 

 
 

Figure 3-18: Print Setup Window 

 

1. Ensure the table you want to print is the active window. 

2. Print the file in any of the following four ways: 

 Click the File menu, then click the Print menu item. 

 Press Alt-F to activate the File menu, then press P to select the Print menu item. 

 Press Ctrl-P to directly activate this command without having to go through the File menu. 

 Click on the Print toolbar button.  

3. Your pc’s standard Print Setup window will appear (see Figure 3-18) and you can select certain 

properties about the print job such as the destination printer, or whether to print in portrait or 

landscape formats. 

4. Once you have selected the print job properties, click on the OK button to send the file to print. 

 If you prefer not to print the file, click the Cancel button to stop the operation. 
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Appendix A – Processing  Messages 

This section describes the processing messages that can be generated by WinVDYP7 and the other 

interfaces. These messages may be generated if you attempt to perform some activity or enter some 

data that WinVDYP7 says is an error.  The errors pop up in a window to inform you of the problem.  

The error messages listed below are in alphabetic order. 

This table lists each error generated, provides a full explanation of the cause, and suggests a way to 

fix the problem to stop the error from occurring in the future. 

Message Severity Cause Resolution 

Actual Percent 
Stockable Area Used: 
xx.x% 

Warning The Percent 
Stockable Area 
actually used was 
not specified and 
had to be 
calculated. 

Explicitly supply the Percent Stockable 
Area parameter. 

An attempt to obtain 
projected values from 
VDYP7CORE for the 
stand age xxx failed. 

Error A request for 
projected values at 
a particular age 
failed. 

Ensure the requested age is valid. 

An error occurred 
processing the 
FIPSTART model.  
VDYP7CORE return 
code: ‘xxx’ 

Error Some aspect of the 
input data 
prevented the 
FIPSTART model 
from converting the 
stand into a VDYP7 
stand. 

Check the return codes for the error ‘FIP 
Model Generated Error Message: xxx’ to 
determine resolution. 

An error occurred 
processing the 
VRISTART model. 
VDYP7CORE return 
code: '’xxx’ 

Error Some aspect of the 
input data 
prevented the 
VRISTART model 
from converting the 
stand into a VDYP7 
stand. 

Check the return codes for the error ‘VRI 
Model Generated Error Message: xxx’ to 
determine resolution. 

An error occurred 
writing the VRISTART 
polygon record. 
VDYP7CORE return 
code: xxx 

Error Internal error 
indicating a File I/O 
problem of some 
kind. 

Internal error.  Ensure sufficient disk 
space exists in the VDYP7 installation 
drive and if so, bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

Attempt to process an 
unrecognized Start 
Model 

Fatal Internal error 
indicating a corrupt 
polygon descriptor. 

Internal error.  Bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 
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Message Severity Cause Resolution 

BA 12.5cm+ (xx.xxx) 
exceeds BA 7.5cm+ 
(yy.yyy). No 
adjustments will take 
place. 

Warning Stand adjustments 
were requested but 
BA 12.5cm+ 
exceeds BA 
7.5cm+. 

Ensure BA 7.5cm+ is at least as great as 
BA 12.5cm+. 

BA 12.5cm+ not 
supplied. No 
adjustments will take 
place. 

Warning Stand adjustments 
were requested but 
BA 12.5 cm+ 
adjustment was not 
supplied. 

Supply an explicit BA 12.5cm+ in order to 
allow Stand Adjustments to take place. 

BA 7.5cm+ not 
supplied. No 
adjustments will take 
place. 

Warning Stand adjustments 
were requested but 
BA 7.5 cm+ 
adjustment was not 
supplied. 

Supply an explicit BA 7.5cm+ in order to 
allow Stand Adjustments to take place. 

Basal Area and Trees 
per HA computed using 
Default CC of xx.x% 

Warning Basal Area and/or 
Trees per Hectare 
had to be inferred 
from the Crown 
Closure 

Explicitly specify the Basal Area and 
Trees per Hectare. 

BEC Zone was not 
supplied. 

Error The BEC Zone was 
not supplied.  This 
is a required input 
for the VRISTART 
process. 

Specify a valid BEC Zone. 

CC was not supplied. 
No leading species 
exists to determine a 
default Crown Closure. 

Error CC was not 
supplied and not 
enough information 
was available to 
compute a default 
value. 

Supply an explicit Crown Closure or 
supply a leading species and BEC zone. 

CC was not supplied. 
Using a default CC of 
xx.x% for leading 
species 'yy' 

Warning CC was not 
supplied and a 
default value was 
computed based on 
species and BEC. 

Supply an explicit Crown Closure. 

Estimated SI applied 
from older species 'xx' 
to younger species 'yy' 

Info An estimated Site 
Index value was 
applied from an 
older (30 years or 
older) leading 
species to a 
younger secondary 
species (less than 
30 years total age). 

This is normal processing.  There is 
nothing to be done. 
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Message Severity Cause Resolution 

FIP Model Generated 
Error Message: xxx 

Error FIPSTART failed to 
convert the stand.  
Possible values for 
xxx are: 

-100 Indicates input 
data was expected 
but not available. 

-12 Low predicted 
Basal Area. 

-11 Site index was 
not supplied. 

-10 YTBH was not 
available. 

-4 Height was too 
low. 

For the following values: 

-100 Internal error.  Bundle up your 
VDYP.INI, TABLEDEF.INI, 
WinVDYP version number and 
details of the model you were 
trying to run and send to technical 
support. 

-12 Increase the parameters 
influencing basal area.  These 
include age, height, and site index. 

-11 Ensure a species occurs with an 
associated age and height is 
specified. 

-10 Ensure a species occurs with an 
associated age and height is 
specified. 

-4 Increase the height of the species 
or the assigned site index. 

FIP Model was 
specified but was not 
actually run. 

Fatal The defined model 
requires that 
FIPSTART be used 
to convert the stand 
into a VDYP7 stand 
for projection.  
However an 
internal error 
prevented 
FIPSTART from 
being started. 

Internal error.  Bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

For species 'xxx', the 
associated reporting 
utilization level is 
invalid: yyy 

Fatal Internal error 
indicating a corrupt 
polygon descriptor. 

Internal error.  Bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

Height xx.x at 
Projection Age yyy is 
too short to generate 
yields for species 'zz' 

Info A species was too 
short for projections 
to occur. 

Increase the site index or height of the 
species in question. 

Invalid Start Model 
returned from 
V7Ext_InitialProcessing
ModeToBeUsed 

Fatal Internal error 
indicating a corrupt 
polygon descriptor. 

Internal error.  Bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

Layer Species Array 
has not been 
associated with this 
polygon layer. 

Fatal Internal error 
indicating a corrupt 
polygon descriptor. 

Internal error.  Bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 
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Message Severity Cause Resolution 

No yields produced. 
Sufficient height was 
not achieved. 

Warning The stand did not 
reach a 
merchantable size 
over the entire age 
range requested in 
the table.  No 
projected volumes 
are produced. 

Increase the productivity of the stand 
through the Site Index and Stand Density 
parameters or change the age range of 
the generated table. 

Primary Layer does not 
contain a Stand 
Description and is 
labeled with Non-
Productive code: 'xxxx'. 

Error An attempt was 
made to project a 
non-productive 
polygon with no 
stand description  

Supply an explicit stand description and 
do not flag the stand as non-productive. 

Projected data for 
species 'xx' was not 
generated at stand age 
yyy 

Info A species dropped 
out of the stand as 
a projection went 
forward. 

Increase the relative percent of the 
species to keep it in the stand for longer 
periods. 

Projected data for the 
layer was not 
generated at stand age 
xxx 

Info All species in the 
stand became non-
merchantable as 
the projection went 
forward. 

Increase the productivity of the stand. 

Secondary SP0 'xx' 
height yy.y at age zz.z 
suppressed next to tall 
lead SP0. 

Warning A tree species less 
than Breast Height 
was encountered 
next to the lead 
species 6m or 
taller. 

Set secondary tree heights to be either 
not supplied (-9.0) or greater than breast 
height (1.3m). 

Species array for Layer 
'x' has not been 
allocated. 

Fatal Internal error 
indicating a corrupt 
polygon descriptor. 

Internal error.  Bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

Species Reporting 
Level array not 
assigned to the 
Polygon Handle. 

Fatal Internal error 
indicating a corrupt 
polygon descriptor. 

Internal error.  Bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

Species 'xx' duplicates 
a species already in 
layer 'xx' 

Error An attempt was 
made to supply two 
identical species 
into the stand. 

Combine the two species and submit the 
stand for processing. 

Stand description not 
possible after 80 years 
of projection. 
VDYP7CORE return 
code: 'xxx' 

Warning The stand 
productivity is so 
low that a 
merchantable 
volume could not 
be determined. 

Increase the stand productivity by 
increasing the site index. 
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Message Severity Cause Resolution 

Unable to locate a 
Primary Layer 

Error The projection 
process could not 
determine a 
Primary Layer for 
projection. 

Internal error.  Bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

Unable to obtain actual 
FIPSTART/VRISTART 
processing info. 
VDYP7CORE Error 
code returned: xxx 

Error Internal error 
indicating a corrupt 
polygon descriptor. 

Internal error.  Bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

Unable to Project Stand 
over age range: xxx to 
yyy. 

Error An age range was 
requested but the 
projection failed 
over that age 
range. 

Ensure the age range is valid. 

Unable to retrieve initial 
VRIADJST Adjustment 
Seeds. VDYP7CORE 
Return Code: xxx 

Error Internal error 
indicating a File I/O 
problem of some 
kind. 

Internal error.  Ensure sufficient disk 
space exists in the VDYP7 installation 
drive and if so, bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

Unable to write 
FIPSTART End of 
Layers marker record. 
VDYP7CORE return 
code: xxx 

Error Internal error 
indicating a File I/O 
problem of some 
kind. 

Internal error.  Ensure sufficient disk 
space exists in the VDYP7 installation 
drive and if so, bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

Unable to write 
FIPSTART End of 
Species marker record. 
VDYP7CORE return 
code: xxx 

Error Internal error 
indicating a File I/O 
problem of some 
kind. 

Internal error.  Ensure sufficient disk 
space exists in the VDYP7 installation 
drive and if so, bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

Unable to write 
FIPSTART Layer 
Record. VDYP7CORE 
return code: xxx 

Error Internal error 
indicating a File I/O 
problem of some 
kind. 

Internal error.  Ensure sufficient disk 
space exists in the VDYP7 installation 
drive and if so, bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 
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Message Severity Cause Resolution 

Unable to write out 
FIPSTART Polygon 
record. Return Code 
from VDYP7CORE: xxx 

Error Internal error 
indicating a File I/O 
problem of some 
kind. 

Internal error.  Ensure sufficient disk 
space exists in the VDYP7 installation 
drive and if so, bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

Unable to write out 
FIPSTART species 
record for the following 
species group: 'xxx' 

Error Internal error 
indicating a File I/O 
problem of some 
kind. 

Internal error.  Ensure sufficient disk 
space exists in the VDYP7 installation 
drive and if so, bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

Unable to write the 
VRISTART Layer 
record. VDYP7CORE 
Return Code: xxx 

Error Internal error 
indicating a File I/O 
problem of some 
kind. 

Internal error.  Ensure sufficient disk 
space exists in the VDYP7 installation 
drive and if so, bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

Unable to write 
VRIADJST Adjustment 
record. VDYP7CORE 
Return Code: xxx 

Error Internal error 
indicating a File I/O 
problem of some 
kind. 

Internal error.  Ensure sufficient disk 
space exists in the VDYP7 installation 
drive and if so, bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

Unable to write 
VRIADJST End of 
Adjustments marker 
record. VDYP7CORE 
Return Code: xxx 

Error Internal error 
indicating a File I/O 
problem of some 
kind. 

Internal error.  Ensure sufficient disk 
space exists in the VDYP7 installation 
drive and if so, bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

Unable to write 
VRISTART End of 
Layer marker record. 
VDYP7CORE return 
code: xxx 

Error Internal error 
indicating a File I/O 
problem of some 
kind. 

Internal error.  Ensure sufficient disk 
space exists in the VDYP7 installation 
drive and if so, bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

Unable to write 
VRISTART End of Site 
Index marker record. 
VDYP7CORE return 
code: xxx 

Error Internal error 
indicating a File I/O 
problem of some 
kind. 

Internal error.  Ensure sufficient disk 
space exists in the VDYP7 installation 
drive and if so, bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 
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Message Severity Cause Resolution 

Unable to write 
VRISTART End of 
Species marker record. 
VDYP7CORE return 
code: xxx 

Error Internal error 
indicating a File I/O 
problem of some 
kind. 

Internal error.  Ensure sufficient disk 
space exists in the VDYP7 installation 
drive and if so, bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

Unable to write 
VRISTART Site Index 
record for species 
group 'xxx' 

Error Internal error 
indicating a File I/O 
problem of some 
kind. 

Internal error.  Ensure sufficient disk 
space exists in the VDYP7 installation 
drive and if so, bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

Unable to write 
VRISTART Species 
record for species 
group 'xxx'. 

Error Internal error 
indicating a File I/O 
problem of some 
kind. 

Internal error.  Ensure sufficient disk 
space exists in the VDYP7 installation 
drive and if so, bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

Unknown Growth 
Model (not FIP/VRI) 
was specified. 

Fatal An internal error 
prevented 
WinVDYP from 
classifying the 
stand properties. 

Internal error.  Bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

V_CU 12.5cm+ 
(xxxx.xxx) exceeds 
WSV 12.5cm+ 
(yyyy.yyy). No 
adjustments will take 
place. 

Warning Stand adjustments 
were requested but 
Close Utilization 
Volume 12.5cm+ 
exceeds Whole 
Stem Volume 
12.5cm+. 

Ensure Whole Stem Volume 12.5cm+ is 
at least as great as Close Util Volume 
12.5cm+. 

V_CU 12.5cm+ not 
supplied. No 
adjustments will take 
place. 

Warning Stand adjustments 
were requested but 
Close Util Volume 
12.5 cm+ 
adjustment was not 
supplied. 

Supply an explicit Close Util Volume 
12.5cm+ in order to allow Stand 
Adjustments to take place. 

V_D 12.5cm+ 
(xxxx.xxx) exceeds 
V_CU 12.5cm+ 
(yyyy.yyy). No 
adjustments will take 
place. 

Warning Stand adjustments 
were requested but 
Decay Volume 
12.5cm+ exceeds 
Close Util Volume 
12.5cm+. 

Ensure Decay Volume 12.5cm+ is at least 
as great as Close Util Volume 12.5cm+. 
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Message Severity Cause Resolution 

V_D 12.5cm+ not 
supplied. No 
adjustments will take 
place. 

Warning Stand adjustments 
were requested but 
Decay Volume 12.5 
cm+ adjustment 
was not supplied. 

Supply an explicit Decay Volume 12.5cm+ 
in order to allow Stand Adjustments to 
take place. 

V_DW 12.5cm+ 
(xxxx.xxx) exceeds 
V_D 12.5cm+ 
(yyyy.yyy). No 
adjustments will take 
place. 

Warning Stand adjustments 
were requested but 
Decay, Waste 
Volume 12.5cm+ 
exceeds Decay 
Volume 12.5cm+. 

Ensure Decay, Waste Volume 12.5cm+ is 
at least as great as Decay Volume 
12.5cm+. 

V_DW 12.5cm+ not 
supplied. No 
adjustments will take 
place. 

Warning Stand adjustments 
were requested but 
Decay, Waste 
Volume 12.5 cm+ 
adjustment was not 
supplied. 

Supply an explicit Decay, Waste Volume 
12.5cm+ in order to allow Stand 
Adjustments to take place. 

VRI Model Generated 
Error Message: xxx 

Error VRISTART failed to 
convert the stand.  
Possible values for 
xxx are: 

-100 Indicates input 
data was expected 
but not available. 

-99 Unknown 
reason for failure. 

-14 Not 
merchantable after 
80 years 

-13 Low predicted 
Basal Area. 

-12 BEC Zone 
missing or Bad 

-9 Crown Closure 
missing. 

-8 Species 
percents do not 
sum to 100% 

-7 Basal Area or 
Trees Per Hectare 
missing. 

-6 Missing 
dominant height. 

-5 Missing Stand 
Age. 

-4 Missing Site 
Index 

For the following values: 

-100, -99, -12, -9, -8, -7, -6, -5, -4 

These values indicate an internal error 
within WinVDYP.  Bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

-14 Increase the productivity of the site 
through age, height, site index 
modifications. 

-13 Increase the stand density 
parameters predicting basal area. 

-3 Adjust Age, Height or SI so that the 
triplet falls within an acceptable 
range. 
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Message Severity Cause Resolution 

-3 The combination 
of Age, Height and 
SI was inadequate. 

VRI Model was 
specified but was not 
actually run. 

Fatal The defined model 
requires that 
VRISTART be used 
to convert the stand 
into a VDYP7 stand 
for projection.  
However an 
internal error 
prevented 
VRISTART from 
being started. 

Internal error.  Bundle up VDYP.INI, 
TABLEDEF.INI, WinVDYP7 version 
number, and details of the model you 
were trying to run and send to technical 
support. 

WSV 12.5cm+ 
(xxxx.xxx) exceeds 
WSV 7.5cm+ 
(yyyy.yyy). No 
adjustments will take 
place. 

Warning Stand adjustments 
were requested but 
Whole Stem 
Volume 12.5cm+ 
exceeds Whole 
Stem Volume 
7.5cm+. 

Ensure WSV 7.5cm+ is at least as great 
as WSV 12.5cm+. 

WSV 12.5cm+ not 
supplied. No 
adjustments will take 
place. 

Warning Stand adjustments 
were requested but 
WSV 12.5 cm+ 
adjustment was not 
supplied. 

Supply an explicit WSV 12.5cm+ in order 
to allow Stand Adjustments to take place. 

WSV 7.5cm+ not 
supplied. No 
adjustments will take 
place. 

Warning Stand adjustments 
were requested but 
WSV 7.5 cm+ 
adjustment was not 
supplied. 

Supply an explicit WSV 7.5cm+ in order to 
allow Stand Adjustments to take place. 

Yields are not predicted 
prior to age xxx.x 

Warning The stand did not 
reach a 
merchantable size 
over the entire age 
range requested in 
the table.  
Projected volumes 
prior to this age are 
suppressed. 

Increase the productivity of the stand 
through the Site Index and Stand Density 
parameters or change the age range of 
the generated table. 
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Appendix B – Revision History 

Version Date Description 

1.0 April 2004 Version 1.0 created, reviewed and approved for distribution 

2.0 January 2006 Version 2.0 created, reviewed and approved for distribution 

2.1 February 2019 Included Third Party copyright notice. 
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Appendix C – Third Party Libraries 

The source code is by and large developed by resources within and contracted by the Ministry of 

Forests, Lands, Natural Resource Operations and Rural Development; the Ministry owns the 

copyright to all source code. 

 

While the bulk of the software is owned by the Ministry, select portions of the software does 

make use of third-party source code. Where that happens, this section will detail that and display 

any copyright notice demanded of its use from its licensing terms: 

 

MINPACK: http://www.netlib.org/minpack/ 

 
Minpack Copyright Notice (1999) University of Chicago.  All rights 

reserved 

 

Redistribution and use in source and binary forms, with or 

without modification, are permitted provided that the 

following conditions are met: 

 

1. Redistributions of source code must retain the above 

copyright notice, this list of conditions and the following 

disclaimer. 

 

2. Redistributions in binary form must reproduce the above 

copyright notice, this list of conditions and the following 

disclaimer in the documentation and/or other materials 

provided with the distribution. 

 

3. The end-user documentation included with the 

redistribution, if any, must include the following 

acknowledgment: 

 

   "This product includes software developed by the 

   University of Chicago, as Operator of Argonne National 

   Laboratory. 

 

Alternately, this acknowledgment may appear in the software 

itself, if and wherever such third-party acknowledgments 

normally appear. 

 

4. WARRANTY DISCLAIMER. THE SOFTWARE IS SUPPLIED "AS IS" 

WITHOUT WARRANTY OF ANY KIND. THE COPYRIGHT HOLDER, THE 

UNITED STATES, THE UNITED STATES DEPARTMENT OF ENERGY, AND 

THEIR EMPLOYEES: (1) DISCLAIM ANY WARRANTIES, EXPRESS OR 

IMPLIED, INCLUDING BUT NOT LIMITED TO ANY IMPLIED WARRANTIES 

OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE 

OR NON-INFRINGEMENT, (2) DO NOT ASSUME ANY LEGAL LIABILITY 

OR RESPONSIBILITY FOR THE ACCURACY, COMPLETENESS, OR 

USEFULNESS OF THE SOFTWARE, (3) DO NOT REPRESENT THAT USE OF 

THE SOFTWARE WOULD NOT INFRINGE PRIVATELY OWNED RIGHTS, (4) 

DO NOT WARRANT THAT THE SOFTWARE WILL FUNCTION 

UNINTERRUPTED, THAT IT IS ERROR-FREE OR THAT ANY ERRORS WILL 
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BE CORRECTED. 

 

5. LIMITATION OF LIABILITY. IN NO EVENT WILL THE COPYRIGHT 

HOLDER, THE UNITED STATES, THE UNITED STATES DEPARTMENT OF 

ENERGY, OR THEIR EMPLOYEES: BE LIABLE FOR ANY INDIRECT, 

INCIDENTAL, CONSEQUENTIAL, SPECIAL OR PUNITIVE DAMAGES OF 

ANY KIND OR NATURE, INCLUDING BUT NOT LIMITED TO LOSS OF 

PROFITS OR LOSS OF DATA, FOR ANY REASON WHATSOEVER, WHETHER 

SUCH LIABILITY IS ASSERTED ON THE BASIS OF CONTRACT, TORT 

(INCLUDING NEGLIGENCE OR STRICT LIABILITY), OR OTHERWISE, 

EVEN IF ANY OF SAID PARTIES HAS BEEN WARNED OF THE 

POSSIBILITY OF SUCH LOSS OR DAMAGES. 
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