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1. INTRODUCTION 
The British Columbia (B.C.) Ministry of Environment and Climate Change Strategy (ENV) Biotic Ligand 
Model (BC BLM) software (Version 1.11) automates the calculation of short-term acute and long-term 
chronic water quality guidelines (WQG) for copper (Cu) for the protection of aquatic life. A full technical 
description of the toxicity data set and derivation procedure can be found in the Copper Water Quality 
Guideline for the Protection of Freshwater Aquatic Life-Technical Report1 document. The software uses 
two separate toxicity databases for chronic and acute Cu exposures for a diverse mixture of aquatic 
organisms, including plants, invertebrates, fish, and amphibians. The BC BLM software is used to 
normalize the toxicity database to site-specific water chemistry, which allows for consideration of the 
effects of certain water quality parameters on bioavailability. The BC BLM software requires the input of 
site-specific water quality information to calculate guideline values. The user can choose to run either 
the full BLM model that requires 11 input parameters or the simplified model that requires 4 input 
parameters and estimates the others.   

The BC BLM2 software is based on the BLM software created by Windward Environmental (version 
3.40.2.45). Note that BLM data files created using the older version of the BLM Windows® Interface can 
be used directly with BC BLM. 

This document describes the requirements for running the BC BLM software, details the data 
requirements, and provides a step-by-step guide to using the various features using an example BLM 
data file.  

2. SETUP AND INSTALLATION 

2.1. SYSTEM REQUIREMENTS 
The BC BLM software is designed for use with Microsoft Windows®. The minimum requirements and the 
recommended system configurations are described below.  

• Minimum system requirements 
✓ PC-compatible, Intel Pentium 233 MHz 
✓ Microsoft Windows® 95/98/2000/ME/XP/Vista/Win7 
✓ 32 MB RAM 
✓ 30 MB free disk space 

• Recommended system configuration 
✓ Intel Pentium 3,500 MHz 
✓ 64 MB RAM 
✓ 100 MB free disk space 

Even though the BC BLM software can be run on a system with the specified minimum requirements, 
the recommended system configuration or faster is recommended to minimize computation time.  

2.2. INSTALLING THE BC BLM SOFTWARE 
Install the BC BLM software from the setup file “bc_blm_setup.exe“ and follow the prompts. The setup 
program will guide the user through a straightforward installation process, querying the user for 
information on where to install the necessary files (Figure 2.1). During the installation, a shortcut to the 
BC BLM application will be added to the ‘Programs’ sub-menu within the ‘Start’ menu on the Microsoft 

                                                           
1 Available at: https://www2.gov.bc.ca/assets/gov/environment/air-land-water/water/waterquality/water-quality-
guidelines/approved-wqgs/copper/bc_copper_wqg_aquatic_life_technical_report.pdf  
2 Available at: https://www2.gov.bc.ca/assets/gov/environment/air-land-water/water/waterquality/water-quality-
guidelines/approved-wqgs/copper/bc_blm_setup.exe 

https://www2.gov.bc.ca/assets/gov/environment/air-land-water/water/waterquality/water-quality-guidelines/approved-wqgs/copper/bc_copper_wqg_aquatic_life_technical_report.pdf
https://www2.gov.bc.ca/assets/gov/environment/air-land-water/water/waterquality/water-quality-guidelines/approved-wqgs/copper/bc_copper_wqg_aquatic_life_technical_report.pdf
https://www2.gov.bc.ca/assets/gov/environment/air-land-water/water/waterquality/water-quality-guidelines/approved-wqgs/copper/bc_blm_setup.exe
https://www2.gov.bc.ca/assets/gov/environment/air-land-water/water/waterquality/water-quality-guidelines/approved-wqgs/copper/bc_blm_setup.exe
https://www2.gov.bc.ca/assets/gov/environment/air-land-water/water/waterquality/water-quality-guidelines/approved-wqgs/copper/bc_blm_setup.exe
https://www2.gov.bc.ca/assets/gov/environment/air-land-water/water/waterquality/water-quality-guidelines/approved-wqgs/copper/bc_blm_setup.exe
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Windows® desktop. In addition, the BC BLM application will also be registered in the system registry so 
that the BLM data files created by the user can be accessed directly by just double-clicking on the file 
name. 

 
Figure 2.1. Installation directory screen for the BC BLM software setup program. 

3. STARTING THE APPLICATION 
To start the BC BLM, select ‘Start -----> Programs -----> British Columbia Copper Biotic Ligand Model -----
> British Columbia Copper Biotic Ligand Model’ on the Microsoft Windows® desktop. The user will be 
presented with the screen shown in Figure 3.1., which contains the user input areas and the various 
functions of the BC BLM. 

 

Figure 3.1. Opening screen for the BC BLM application. 
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Existing BLM data files created using other versions of the BLM Windows® Interface can be opened 
directly by double-clicking on the file name through a file system manager, such as Microsoft Windows® 
Explorer. 

4. RUNNING THE APPLICATION 
The following subsections describe the various functions and features available in the BC BLM 
Windows® Interface and its various predictive capabilities. 

4.1. Quick Start Guide 
Steps 1-7 provide an overview of the user’s manual for quick application of the BC BLM. More details are 
provided in the following subsections.    

Step 1: Enter water chemistry data or upload a saved ‘.blm’ or ‘.blme’ file (see sections 4.6 and 4.3.1); 

Step 2: Save file on the desired destination on your computer (see Section 4.3.1); 

Step 3: Select chronic/acute database (see Section 4.3.4);  

Step 4: Select quick normalization if >3 sites are being run to improve run times (see Section 4.3.3.); 

Step 5: Select run (see Section 4.4.4); 

Step 6: Open the output directory suggested by the software (see Section 4.4.4); 

Step 7: Obtain the acute/chronic WQG from the ‘.txt’ file produced by the software (see Section 6). 

4.2. Description of Interface 
Figure 4.1 shows the BC BLM application. The interface provides an easy-to-use editor to construct input 
files for the BC BLM containing site-specific water chemistry data, checks and validates user input data 
to ensure the values entered for any given parameter are within the range for which the BC BLM has 
been calibrated, and runs the BC BLM to calculate WQGs. The interface window is divided into four 
areas based on their functionality. Each of these is described in the following subsections. 

 

Figure 4.1. Opening screen for the BC BLM application. 

4.3. Menu Bar 
The Menu Bar located at the top of the interface window provides the user with a range of functions 
and features described in the following sections. 
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4.3.1. File 

The File menu (Figure 4.2) includes basic file management utilities to: create a new BLM data file (New); 
open an existing BLM data file (Open…); save a BLM data file (Save); and save a BLM data file under a 
different name or in a new location (Save as…). Shortcut keys (shown to the right of each item) are also 
available for the different functions in this menu item. Note that the BC BLM data files created by the 
interface application are given a ‘.blm’ or ‘blme’ extension for full or simplified chemistry, respectively. 
Clicking the ‘Open’ icon while in the full or simplified site chemistry tabs will filter for files with the 
extension of ‘.blm’ or ‘.blme’, respectively. 

 

Figure 4.2. Snapshot of “File” menu item. 

BLM data files can also be opened directly by double-clicking on the BLM data file in a file system 
manager, such as Microsoft Windows® Explorer. This avoids having to first start the application and then 
navigate through the file menu to locate the BLM data file of interest. 

The Run Batches…function can be used to run several input files simultaneously. 

The Quit function can be used to quit BC BLM application. 

4.3.2. Edit 

The Edit menu provides basic editing functions such as Copy, Cut, and Paste (Figure 4.3). These functions 
can be performed on a single cell or multiple cells by highlighting the cell with the cursor (left click and 
drag) or by using the Shift + Arrow functions on the keyboard. The editing functions can also be applied 
using the shortcut keys shown to the right of each function. Note that it is also possible to copy and 
paste data from external programs, such as spreadsheet applications, into the BC BLM. 

 

Figure 4.3. Snapshot of Edit menu item. 
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4.3.3. Options 

Figure 4.4 shows the functions available under the Options menu.   

Quick Normalization 

The chronic and acute databases used to calculate WQGs in the BC BLM consist of 319 and 730 data 
points, respectively. The WQG calculation process may take a long time, particularly if several water 
chemistry scenarios are running at the same time. Thus, a Quick Normalization feature is provided under 
the Options menu which normalizes data for only the most sensitive species, rather than the whole 
database. The application of this feature reduces the run time significantly. However, less information 
will be provided by using this feature. The normal run can be used when more information is needed for 
individual sites. 

 

Figure 4.4. Snapshot of Options menu item. 

Show Engine Runs 

The run may take up to an hour when running several sites simultaneously, depending upon the 
computing power available. In these cases, it is recommended to select the Show Engine Runs option to 
show the software’s progress allowing the user to ensure the software is working properly. 

4.3.4. Inputs 

Figure 4.5 shows the options available under the Inputs menu. The units for all parameters can be 
changed by selecting the Set Units function. For each component, the available units are displayed in the 
Select Units menu to the right. The Dissolved Inorganic Carbon (DIC) concentration is needed to run BC 
BLM. DIC can be calculated from alkalinity and since alkalinity is a more routinely measured, BC BLM 
requests for alkalinity data by default. However, the Set Inorganic Carbon function allows the user to 
input DIC instead of alkalinity in case of availability. If neither of measured DIC or Alkalinity data is 
available, DIC can be estimated from atmospheric CO2.  

Database Option allows the user to specify the calculation of either acute or chronic WQGs. 

 

Figure 4.5. Snapshot of Inputs menu item. 
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4.3.5. Help 

The User’s Guide for the BC BLM can be accessed under the Help menu item (Figure 4.6). The About BLM 
option provides contact information for technical support. The Create Debug Log can be used to directly 
contact the developers of BC BLM (Windward Environmental) if the user faces a problem while working 
BC BLM.  

 
Figure 4.6. Snapshot of Help menu item. 

4.3.6. Language 

The user can select either English or French from the Language menu item.  

4.4. Tool Bar 
The Tool Bar provides shortcuts to some BC BLM functions (Figure 4.7). 

 

Figure 4.7. Tool Bar menu icons. 

4.4.1. Standard File Operations 

New File: this shortcut allows the user to create a new file for water chemistry input (Section 4.3.1). 

Open File: this shortcut provides quick access to the BC BLM data files (Section 4.3.1). If the BC BLM data 
file being edited has changed since the last time it was saved and the user tries to open another file, the 
user will be asked if the current data file should be saved prior to opening another. 

Save File: this shortcut allows quick saving of the BC BLM data file (Section 4.3.1). The data file will be 
saved with the same, existing name. If the user wishes to save the file under a different file name, the 
menu bar item File → Save As should be chosen. 
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4.4.2. Standard Edit Operations 

Shortcuts for basic editing functions such as Copy, Cut, and Paste are provided and can be used to edit 
the water chemistry data at any point (Section 4.3.2). 

4.4.3. Check Inputs 

The range of parameter values used to develop and calibrate the BC BLM are listed in Table 4.1. These 
ranges were taken from chronic and acute toxicity studies that considered the effects of water 
chemistry (e.g., pH, DOC, or hardness cations) on Cu bioavailability. The BC BLM is only valid within 
these data ranges. After creating a BC BLM data file, the user may wish to check the water chemistry 
inputs to verify whether the parameter values are within the overall range for which the BC BLM has 
been calibrated, and to see whether data for all the parameters necessary for a BC BLM prediction have 
been specified. Clicking on this icon generates an input check report that contains information on which 
parameters are out of range (i.e., too high or too low when compared with the range for which the BC 
BLM has been calibrated) and which parameters are missing for any given input row. Figure 4.8 shows 
an example of an input check report. 

If water quality input values are greater or less than these ranges, the BC BLM software automatically 
applies the upper or lower bounds while calculating WQGs. 

Table 4.1. Ranges of values for BLM input parameters. 

Parameter Lower Bound Upper Bound 

Temperature (oC) 5.5 27 

pH 4.7 9.0 

DOC (mg/L) 0.05 20 

Humic acid content (%) 0.01 99 

Calcium (mg/L) 2.2 72.94 

Magnesium (mg/L) 0.48 18.4 

Sodium (mg/L) 0.86 70.97 

Potassium (mg/L) 0.59 156 

Sulfate (mg/L) 0.5 1320 

Chloride (mg/L) 0.2 119.8 

Alkalinity (mg/L) 3 160 

Hardness (mg/L) 7.8 236.8 
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Figure 4.8. Example of an “Input Check Report” generated by the Check Inputs function. 

4.4.4. Run BLM 

The Run BLM icon is used to launch the BC BLM program to calculate WQGs for the user-specified water 
chemistry in the data file currently open. If the data file has unsaved changes, the user is given the 
option of saving the changes prior to running the BC BLM. The program will use either the chronic or 
acute database, depending on which database was selected from the Inputs Menu (see Section 4.3.4), 
and calculates the WQG for each row in the database. The runtime for BC BLM calculations can vary 
from a few seconds to a few hours depending on the number of input rows in the data file and the 
database selected (chronic or acute). Selecting the Quick Normalization option will reduce the run time 
considerably (see Section 4.3.3). Upon completion, the user is informed of the names and the locations 
of the output files, and given the option to open the directory, as shown in Figure 4.9. 

 

Figure 4.9. Example of the notification window shown at completion of BC BLM run. 

4.5. Data File Description 
The Data File Description field (Figure 4.10) allows the user to insert comments describing the BC BLM 
data file which will be saved with the water chemistry data entered by the user. Although this function is 
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not critical to the function of the BC BLM, it is useful for record-keeping and quality assurance/quality 
control purposes. 

 

Figure 4.10. Snapshot of BC BLM application  

Item Description 

Located at the very bottom of the interface window, this area displays a brief description of the feature 
over which the cursor is currently positioned. 

4.6. Site Chemistry Input Tabs 
There are two options for entering the water chemistry data depending on the parameters available: 
Site Chemistry (i.e., full site chemistry) and Simplified Site Chemistry.     

4.6.1. Site Chemistry  

This region of the interface window contains a spreadsheet-based editor, which organizes the various BC 
BLM input data in a columnar format such that the chemistry for each discrete water sample can be 
specified in a separate row. Two additional columns are provided for labeling the sites and samples in a 
given BC BLM data file. Figure 4.11 shows the columns available for user input. 

 

Figure 4.11. Columns for data input in the BC BLM. 

The BC BLM predicts Cu toxicity in aquatic systems and calculates WQGs for a site based on the ambient 
water chemistry. The user is required to provide data describing the physical and chemical properties of 
the site water. The data requirements of the BLM are conventional physical and chemical parameters 
that are listed in Table 4.2. Some of these parameters have an important effect on BC BLM predictions, 
while others have only minor effects. 
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Table 4.2. Water chemistry factors necessary to run the BC BLM, their unit and relative importance in calculation of 
WQGs. 

Factor Unit Importance 

Temperature °C Low 

pH NA High 

Dissolved organic carbon (DOC) mg/L High 

Humic acid fraction of DOC % Low 

Calcium mg/L High 

Magnesium  mg/L High 

Sodium  mg/L High 

Potassium  mg/L Low 

Sulfate mg/L Low 

Chloride mg/L Low 

Alkalinity mg/L High 

Copper concentrations are not required for the model to calculate WQGs, however, this field is retained 
to allow compatibility with other BLM versions. Copper concentrations entered will not affect the WQG 
calculations but are included in the output text file for comparison with the WQG. The input file for the 
BC BLM is compatible with other BLM software versions, such as the US EPA BLM. 

4.6.2. Simplified Site Chemistry 

The Simplified Site Chemistry tab provides an option when all the water chemistry factors are not 
available. It differs from the Site Chemistry tab in that it only requires data for temperature, pH, DOC 
and hardness (mg/L as CaCO3) to run the BC BLM. Selecting the Simplified Site Chemistry tab provides a 
simpler site chemistry data input spreadsheet (Figure 4.12). 

Additionally, there is a side bar where the ion ratios can be set. The ion ratios will vary depending on 
watershed geology. The default values provided are the median ion ratios for B.C. and can be used if the 
ratios are unknown. These values can be changed to match the conditions of the site or test and can be 
reset to the default values at any time by clicking the Restore Default Values button at the bottom of the 
box. The Select Ion Ratios… button allows the user to select default ion ratios for other regions of North 
America. Note that this is not recommended for calculating WQGs in B.C.; this option is included only to 
make the BC BLM compatible with other versions of BLM Windows® Interface. 

After the simplified site chemistry data has been entered, the BC BLM estimates the missing water 
chemistry information while calculating WQGs. 
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Figure 4.12. Snapshot of Simplified Site Chemistry inputs and ion ratios. 

When enough water chemistry data for the simplified option are available (e.g., major ions), but 
insufficient for the full BC BLM, the following steps should be taken: 

• Enter the parameters in the Simplified Site Chemistry tab; 

• Switch to the full Site Chemistry tab and replace the estimates for parameters with the available 
measured values; 

• If alkalinity data are available, the Set Inorganic Carbon option should be selected from the 
Inputs menu and then Closed System, Input Alkalinity should be selected (Figure 4.13). An 
additional column for alkalinity will appear and the data are entered there. 

Note that if you switch back to the Simplified Site Chemistry tab without saving the data, the water 
chemistry data will be deleted. 

 

Figure 4.13. Snapshot of Set Inorganic Carbon menu item. 

5. EXAMPLE APPLICATION 
The BC BLM features an example application for demonstration purposes. This file, named ‘Lake 
Superior.blm,’ is installed along with the BC BLM and is in the “My Documents → British Columbia 
Copper Biotic Ligand Model” folder. The file can be opened directly, by double-clicking on the file name 
through a file-system manager such as Microsoft Windows® Explorer or by first starting the BC BLM and 
selecting the file through the ‘File → Open’ action. This data file ‘Lake Superior.blm’ can be used to 
calculate a Cu WQG example produced by the BC BLM.  
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6. DESCRIPTION OF OUTPUT FILES 
The contents of the output files will appear in an Output tab in the BC BLM User Interface once the 
model has finished running. The main output is written to a text file and saved to the same location as 
the input file, with the same name as the input file but with ‘.results’ appended (Figure 4.14). For 
example, using the input file ‘LakeSuperior.blm’ would create an output file titled 
‘LakeSuperior_Chronic.results.txt’ or ‘LakeSuperior_Acute.results.txt’ depending on the selection of 
Acute or Chronic databases (see Section 4.3.4). The output file includes the site chemistry used, and the 
WQG value calculated for each site. 

In addition, a bitmap image is produced for each site that illustrates the effect concentrations for the 
different species in the toxicity database, normalized to the specified site chemistry (Figure 4.15). Lines 
on the graphic indicate the “Minimum Low Effect Threshold Value” (i.e., most sensitive endpoint) and 
the “Guideline Value” calculated from it. The bitmap file will not be produced in the “Quick 
Normalization” mode. 

A Microsoft Excel® file will also be produced that shows the values associated with the points in this 
graphic, and the species, life stage, endpoint, and endpoint quantifiers associated with each point 
(Figure 4.16). 

 

Figure 6.1. Example of a text file produced by BC BLM. 
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Figure 6.2. Example of the BC BLM graphic output for toxicity thresholds for different species. 

 

Figure 6.3. Example of the Microsoft Excel® file produced by BC BLM. 
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7. UNINSTALLING THE BC BLM 
To uninstall the BC BLM, select the Uninstall Utility using ‘Microsoft Windows® Start Menu → Programs 
→ British Columbia Copper Biotic Ligand Model → Uninstall.’ All files installed by the BC BLM during 
setup will be uninstalled. None of the files created by the user and saved in the BC BLM installation 
directory will be deleted during this process. These need to be manually deleted by the user, if so 
desired. 

 

 

 

 

 

 

 

  


